Du bist nicht angemeldet.

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

41

Mittwoch, 20. Januar 2010, 11:41

alles k.A.

eine offensichtlich zusammenhängende Zahlenreihe unbekannter Länge:
100
104
111
139
167
202
301

setze alle Stellen auf 167:
167
167
167
167
...

Eine veränderung am Widerstand des Gebers wird keine Änderung in der Anzeige (Messwertblock oder Zeiger) hervorrufen.
Jetzt weiss man aber was 167 bedeutet und wozu diese Werte gehören wenn z.b. im Tankgebermesswertblock dauernd 25 Liter steht obwohl man am Tankgebersimulator-Poti dreht!
nächster Versuch mit 202...

ich kann zur Zeit nichts machenn kein Labor vorhanden - renoviere gerade (u.a. mein "Labor")

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

42

Mittwoch, 20. Januar 2010, 13:09

Habe da im Dump schon annähernd was gefunden, eine Wertfolge von 6-8 Angaben die eventuell die Ohmwerte vom Tankgeber sein könnten. Nur anscheinend ist diese zwei mal angegeben. Zwischen der ersten und der zweiten liegt nur ein mir unbekanntes Bit und dann kommen die gleichen Angaben nochmals. Ist das bei den anderen Kennlinien auch so?

Werde mich mal weiter durch das Hex-Dump hangeln, mal sehen was man da noch so findet... Fakt ist ja, dass zwischen den 919er und 920er KIs ein Unterschied der Positionen der dort abgelegten Werte zu bestehen.

Heute Abend werde ich mir mal ein 0-500Ohm Poti besorgen und dann mal mit den Messwertblöcken zu experimentieren. Eventuell komme ich damit schon eine ganze Ecke weiter.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mr.b« (20. Januar 2010, 13:14)


mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

43

Donnerstag, 21. Januar 2010, 09:39

Habe mir gestern eine Bedienplatine für meine Teststellung gelötet, da ich ja keinen Wagen da habe, nur das KI und ne Batterie. Darauf sind, zwei Schalter für Dauerplus und Zündung, drei Taster für MFA und Reset, einen 500Ohm Poti für den Tankgeber und einen 1kOhm Poti für den Temperaturgeber. Dabei hängt noch ein Ölstands- und Temperatursensor und der OBD-Stecker.
Funktioniert auch alles, nur die Kühlmittel-Temperaturanzeige nicht. Diese wird doch auch gegen Masse gemessen wie der Tankgeber, oder? Es ändert sich nichts, wenn ich am Poti drehe, auch in VAG-COM nicht, dort zeigt er mir bei der Temperatur nur -45°, ich weiß nur nicht, ob das nicht eventuell die Außentemp ist, da der Sensor dafür nicht dran ist und dafür bekomme ich auch einen Eintrag im Fehlerspeicher.
Für den Kühlmittel-Tempsensor gibts allerdings keinen Fehlerspeicher-Eintrag, in welchem Messwertblock kann ich den Ohm-Wert und den Temperaturwert dafür anzeigen lassen?

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

44

Freitag, 22. Januar 2010, 11:46

So, ich mach hier jetzt mal ein wenig den Alleinunterhalter :D

Habe jetzt in meinen beiden Test-Dumps jeweils 8 ansteigende Wertfolgen gesichtet. Jeweils zwei davon liegen direkt dahinter. Dann kommt ein Byte und dann kommen wieder zwei zusammenliegende Wertfolgen. Und das kommt weiter unten im Dumps nochmal mit exakt den Wertfolgen. Warum auch immer die Werte nochmal vorkommen oder halt doppelt hinterlegt sind.
Ich denke die hintereinander liegenden Wertfolgen ohne zwischen-Byte sind einmal Zeigerstellung und Eingangswert vom Geber.
Die erste Manipulation an einer dieser Wertfolgen hatte gestern leider keinen Erfolg. Ich werde dies jetzt am Wochenende mal etwas ausweiten und die anderen Wertfolgen auch mal bearbeiten um zu schauen, wann ich an die Tankgeber-Linie stoße um diese zu bearbeiten.

Ich berichte denke ich nach dem Wochenende wieder.

Marc_StB

Fortgeschrittener

Beiträge: 247

Registrierungsdatum: 30. Juni 2008

Wohnort: Hamburg

Autos: Golf [too] Turbo

45

Freitag, 22. Januar 2010, 12:24

Auch wenn Du den Alleinunterhalter machst...
ich höre gespant zu. Das Thema finde ich nämlich
selbst sehr interessant. Nur kann ich keine weiterführenden
Informationen geben.

Allerdings habe ich mal gelesen, dass bei der Tankkennlinie
zwei oder drei Stellen (Bytes?) des Dumps identisch sind, weil
der Zeiger am Ende (voll) nicht mehr weitersteigen soll. Das
erklärt auch, warum der Zeiger bei 'Tank voll' zunächst stehenbleibt
und erst später zu sinken anfängt.

LG Marc

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

46

Freitag, 22. Januar 2010, 12:29

Genau das was du über die Tankkennlinie sagst trifft auch zu. Habe diesen Bereich in einigen 919er Dumps identifizieren können.
Dafür sind also 8 Bytes aufgeteilt in leer, Reserve, 1/4, 1/2, 3/4, voll, voll und voll.

Bei den 920er KIs gibt es diese Einteilung scheinbar nicht, jedenfalls kann ich das in keiner der 4 Kennlinie anwenden, welche ich gefunden habe (in allen 920er Dumps die ich habe).

Was mir jetzt immer noch Fragen aufwirft ist, wie steht die Wertfolge vom Zeiger in Verbindung mit der Wertfolge vom Eingangssignal. Stellen die 8 Bytes eine feste Stellung des Zeigers da, welche man nicht verändern kann, man aber die Spreizung zum nächsten Wert somit verkleinern oder vergrößern kann!?

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

47

Samstag, 23. Januar 2010, 11:55

Genau das was du über die Tankkennlinie sagst trifft auch zu. Habe diesen Bereich in einigen 919er Dumps identifizieren können.
Dafür sind also 8 Bytes aufgeteilt in leer, Reserve, 1/4, 1/2, 3/4, voll, voll und voll.

Bei den 920er KIs gibt es diese Einteilung scheinbar nicht, jedenfalls kann ich das in keiner der 4 Kennlinie anwenden, welche ich gefunden habe (in allen 920er Dumps die ich habe).

Was mir jetzt immer noch Fragen aufwirft ist, wie steht die Wertfolge vom Zeiger in Verbindung mit der Wertfolge vom Eingangssignal. Stellen die 8 Bytes eine feste Stellung des Zeigers da, welche man nicht verändern kann, man aber die Spreizung zum nächsten Wert somit verkleinern oder vergrößern kann!?
da gibt es doch einen Messwertblock mit "Litern" (Tankinhalt) ? was zeigt der ?
Eventuell sind es 2 Kennlinien - 1x Ohm/Liter und 1x Liter/Spannung für den Zeigerservo.

Oder aber die Servos sind so genau das man nur eine Kennlinie hat.
Dann gibt es irgendwo einen Liter-Wert der Tank-Voll represäntiert...

Also zuerst bitte auf den Liter Wert im Messwertblock gucken.

Stell den Poti in die Mitte - schreibe überall den Mittelwert in die Kennlinie und sage welcher Hexwert was anzeigt. (Messwertblock UND Zeiger!). Und dann am Poti drehen (sollte sich nichts ändern - solange du nicht in den Fehlerbereich kommst -> Kurzschluss nach Masse etc).
Ermittle die Max. und Min. Werte bevor er einen Fehler setzt.
Diese Werte sollten genau irgendwo im EPROM zufinden sein -> Bingo -> Max und Min gefunden.

edit:
Lass den Poti stehen - ändere die Werte - Was ändert sich ? Zeiger oder Liter im Messwertblock ?
Wenn nur Zeiger sich ändert -> Liter/Zeigerservo gefunden !
Wenn Zeiger und Liter sich geändert haben dann hast du Ohm/Liter gefunden.

edit2:
http://www.gti-tdi.de/board2/index.php?p…d&threadID=3204

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »FMode« (23. Januar 2010, 18:20)


mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

48

Montag, 25. Januar 2010, 09:38

Danke FMode für die kleine Erläuterung, hat mir schon etwas weitergeholfen.

Habe mir den ganzen Samstag Nachmittag mit meinen Hex-Dumps beschäftigt und habe an den vier von mir gefundenen Kennlinie rumexperimentiert. Jedenfalls habe ich die Kennlinie für Liter/Ohm-Eingang gefunden und diese schon erfolgreich bearbeiten können.
Habe als ersten die Kennlinie einfach umgedreht, sodass mein Poti einfach erstmal andersherum zu drehen war. Somit passte dann auch Ohm zu Liter, nur andersrum.
Das ist schon mal geschafft. Jetzt werde ich die Tage mal meinen Tank vom Karosseriebauer abholen, diesen voll tanken und dann Liter für Liter abpumpen und mir die richtigen Ohm-Werte des Golf 3 Tankgebers notieren. Daraus versuche ich dann eine Kennlinie abzuleiten und in das KI einzuprogrammieren. Und dann halt auch Liter für Liter wieder einfüllen und das KI anschließen um zu schauen, wie genau die Kennlinie dann arbeitet.

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

49

Mittwoch, 27. Januar 2010, 08:08

Habe mich gestern nochmal ein paar Stunden mit meinem originalen Hex-Dump beschäftigt, mal einfach um diese ganzen Kennlinie zu verstehen, welche ich gefunden habe.
Fakt ist, dass mein KI umschalten kann zwischen 52,5 und 60 Liter, also Frontantrieb und Quattro. Dazu gibt es jeweils zwei Kennlinie (2x 16-Bit-Reihen) mit einer Zuordnung von Ohm zu Liter, und Liter zu Zeigerstellmotor. Auf die Liter-Werte bin ich ganz schnell gekommen und den Stellmotor kann man auch leicht identifizieren. Bleibt nur noch die Kennlinie für den Ohm-Eingang vom Tankgeber. Vom Anstieg der Werte her passt das auch mit der Kennlinie überein. Nur was mir noch fehlt, ist die Wertangabe in der Kennlinie. Das scheint nicht der richtige Ohm-Wert zu sein. Bei der Liter-Linie muss man den Wert zwar auch umrechnen, aber bei der Ohm-Linie komm ich nicht drauf. Gleiche Formel wie bei der Liter-Linie lässt sich auf die Ohm-Linie nicht anwenden.
Kann da jemand was zu sagen, als was die Ohm-Kennlinie gespeichert wird?

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

50

Mittwoch, 27. Januar 2010, 10:33

Ach den Ohmwert gibt es auch in einem Messwertblock ?

Dann würde ich sagen gibts noch irgendwo einen Faktor der die Werte des A/D Wandlers relativ zum Ohm-Wert des Gebers beschreibt.

Ansonsten ist natürlich die Bezeichnung "Ohm-Liter" falsch und müsste genau heissen "A/D Wandler - Liter"...

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

51

Mittwoch, 27. Januar 2010, 11:04

Jup, für den Ohm-Wert gibt es auch in Kanal 2 den 3. Block. Also 2. Block ist Liter und 3. Ohm.

Stimmt dann müsste die Kennlinie Liter-->A/D-Wandler heißen.

Ist nur die Frage ob es einen oder mehrere Faktoren gibt für die Berechnung des Ohmwertes, weil ein gleicher Faktor hier anscheinend nicht gegeben ist. Ich meine damit, es für jeden Block in dem ein Wert angegeben ist ein anderen Multiplikator oder Divisor vorhanden sein müsste...

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

52

Mittwoch, 27. Januar 2010, 11:17

?(
ich seh das Problem nicht...
also wenn der Golf 3 Tankgeber oder Poti angeschlossen ist zeigt er die korrekten Ohmwerte im Messwertblock an ?
Was ist mit den Grenzen Max und Min ? Zeigt er die Ohmwerte dann weiter an und setzt eine Fehlermeldung ?

Meintest du das in der 1. Kennlinie "Ohm zu Liter" die Ohmwerte nicht direkt ablesbar stehen ? Dann alle Punkte auf den selben Wert stellen und mehrmals schauen was an Litern angezeigt wird...

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

53

Mittwoch, 27. Januar 2010, 11:41

Ganz ehrlich habe ich es noch nicht mit dem Multimeter nachgemessen, ob das KI den Ohm-Wert richtig anzeigt.

Meinst du die Grenze Min Max vom Widerstand? Der liegt bei etwa 70Ohm für Min und ab 277Ohm für Max, danach geht die Liter-Anzeige auf null.

Also mir fehlt halt der Zusammenhang zwischen den angezeigten Ohm und den Werten in dern Kennlinie. Vom Anstieg verlaufen beide Wertfolgen proportional in etwas gleich.

Zitat

Meintest du das in der 1. Kennlinie "Ohm zu Liter" die Ohmwerte nicht direkt ablesbar stehen ? Dann alle Punkte auf den selben Wert stellen und mehrmals schauen was an Litern angezeigt wird...
Ja genau, als wenn im Messwertblock z.B. 274 Ohm stehen, dann steht in der Kennlinie an dieser Stelle (passend zur Liter-Angabe) 1448 (Divisor 8 = 181 <-- ob das dabei richtig ist weiß ich nicht, bei der Liter-Kennlinie hat das gepasst)... also kann das keine richtige Ohm-Angabe sein... solange ich da keinen Denkfehler drin hab.

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

54

Mittwoch, 27. Januar 2010, 12:55

Ganz ehrlich habe ich es noch nicht mit dem Multimeter nachgemessen, ob das KI den Ohm-Wert richtig anzeigt.

Meinst du die Grenze Min Max vom Widerstand? Der liegt bei etwa 70Ohm für Min und ab 277Ohm für Max, danach geht die Liter-Anzeige auf null.

Also mir fehlt halt der Zusammenhang zwischen den angezeigten Ohm und den Werten in dern Kennlinie. Vom Anstieg verlaufen beide Wertfolgen proportional in etwas gleich.

Ja genau, als wenn im Messwertblock z.B. 274 Ohm stehen, dann steht in der Kennlinie an dieser Stelle (passend zur Liter-Angabe) 1448 (Divisor 8 = 181 <-- ob das dabei richtig ist weiß ich nicht, bei der Liter-Kennlinie hat das gepasst)... also kann das keine richtige Ohm-Angabe sein... solange ich da keinen Denkfehler drin hab.
die Relation muss nicht linear sein (!) sie kann auch logarithmisch sein...

also Potiwert in die Mitte - darauf achten das er immer gleich ist (Messwertblock auch checken!) - ALLE Werte der Kennlinie auf gleichen Wert - Wieviel Liter werden jeweils angezeigt ?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »FMode« (27. Januar 2010, 13:01)


mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

55

Mittwoch, 27. Januar 2010, 15:31

Wovon meinst du den Mittelwert? Ich steig langsam nicht mehr durch... :-3 Den Mittelwert zwischen Min und Max des Tankgebers?
Also ich stelle den Poti in die Mitte, wäre beim 0-500Ohm dann ja 250 Ohm. In der Kennlinie ändere ich alle 8 Wert auf den Mittelwert zwischen 48 und 1448 (wobei 48 im ersten Block steht, und 1448 im letzten), sprich 700. Und was kann ich dann daraus ableiten? Und was wären die nächsten Schritte?

iGoofy

Anfänger

Beiträge: 0

Registrierungsdatum: 27. Januar 2010

56

Mittwoch, 27. Januar 2010, 18:10

Hallo,



ich verfolge diesen Thread mit großer Aufmerksamkeit, hab mich jetzt deshalb sogar hier angemeldet. Großes Lob an deine Mühen bisher!

Vielleicht hilft es dir, wenn du dir die Kennlinien einfach mal in einem Diagramm (Excel, Uniplot,...) darstellst?! Dann könntest du mit Hilfe der logarithmischen Skalierung auch FMode's Vermutung überprüfen.



Vielleicht erklärt dieser Unterschied in den beiden Kennlinien ja auch das unterschiedliche Verhalten von Tankfüllstand zu Tankfüllstandsanzeige? :?:



Grüße und nochmal Hallo im Forum :wink



Torsten

Marc_StB

Fortgeschrittener

Beiträge: 247

Registrierungsdatum: 30. Juni 2008

Wohnort: Hamburg

Autos: Golf [too] Turbo

57

Mittwoch, 27. Januar 2010, 19:18

Der Tankgeber wird im Fahrzustand doch recht ordentlich
hoch und runter bewegt, weil das Benzin im Tank
hin und her schwappt.

Müsste in die Überlegungen so etwas einbezogen werden?
Ich schätze mal, dass der MC in gewissen Zeitabständen
die Widerstandswerte am Tankgeber misst und dann die
im Eeprom hinterlegte Skala nach Durchschnittswerten
abfragt. Dies eröffnet wenigstens die Möglichkeit, dass
nicht die wirklichen Ohm-Werte im Dump enthalten sind.
(Ist aber nur eine Vermutung - und bei sowas habe ich
schonmal daneben gelegen...)

LG Marc

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

58

Mittwoch, 27. Januar 2010, 19:41

Wovon meinst du den Mittelwert? Ich steig langsam nicht mehr durch... :-3 Den Mittelwert zwischen Min und Max des Tankgebers?
Also ich stelle den Poti in die Mitte, wäre beim 0-500Ohm dann ja 250 Ohm. In der Kennlinie ändere ich alle 8 Wert auf den Mittelwert zwischen 48 und 1448 (wobei 48 im ersten Block steht, und 1448 im letzten), sprich 700. Und was kann ich dann daraus ableiten? Und was wären die nächsten Schritte?
es geht darum auch 100% den Wert zu "erwischen" - also wieviel Liter werden bei 700 angezeigt ? (Potiänderungen sollten KEINE Änderung der Literanzeige hervorbringen - bitte bestätigen)

Jetzt das ganze mit sagen wir 800 ?

Ein paar Werte nehmen und vielleicht hilft es mit Excel dann eine Kurve zeichnen zu lassen. (Ansonsten her mit den Werten dann bastel ich daraus eine Kurve - habe ich schonmal gemacht).

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

59

Mittwoch, 27. Januar 2010, 20:19

Okay gut, dann weiß ich jetzt wie du das meinst. Werde mich die Tage mal ranmachen und einige Testreihen machen und meine Tabellen füllen und vielleicht auch ein Diagramm darstellen. Schauen wir mal!

Bei Logarithmen muss ich leider passen, nicht mein Gebiet :P

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

60

Donnerstag, 28. Januar 2010, 21:05

So anscheinend hatte ich die falsche Kennlinie in der Mache. Habe jetzt eine andere am Wickel, wo ich testweise alle Blöcke der Reihe auf einen Wert gestellt hatte. Dann tat sich beim Betätigen des Potis nichts an der Literangabe (immer bei 52l) und auch nicht an der Nadel, bis ich an einen bestimmten Ohm-Wert angelangt war, bis Nadel und Liter auf einmal auf Null fielen.
Darauf hin habe ich acht Test-Dumps fertig gemacht, wo ich je alle Blöcke auf einen Wert der Reihe gestellt hatte. Quasi Datei 1 alle auf Wert 1 aus der original Datei, in der 2. Datei alle Blöcke auf den Wert des 2. Blocks der originalen Datei. Ich hoffe ihr versteht was ich meine :wink
Die Schwelle wann die Nadel und die Literanzeige auf Null gefallen sind, haben sich von Datei zu Datei geändert. Habs mal in ein Diagramm zusammengestellt, und man kann daraus vielleicht was ableiten, ich jedenfalls noch nicht :D



So und hier mal eine 8 eingestellten Werte und die Schwelle, wann die Nadel abgefallen ist:

1. ... 267 ... 72 Ohm->52l ... 71 Ohm->0l
2. ... 302 ... 84 Ohm->52l ... 83 Ohm->0l
3. ... 322 ... 92 Ohm->52l ... 91 Ohm->0l
4. ... 336 ... 99 Ohm->52l ... 98 Ohm->0l
5. ... 385 ... 121 Ohm->25l ... 120 Ohm->0l ... ab 216 Ohm->26l (<-- das irritiert mich ein wenig!)
6. ... 471 ... 172 Ohm->52l ... 171 Ohm->0l
7. ... 537 ... 222 Ohm->52l ... 221 Ohm->0l
8. ... 589 ... 273 Ohm->52l ... 272 Ohm->0l

Die Nadel und Liter fallen im oberen Bereich wieder ab 347 Ohm auf 0.

EDIT: Die Ohm-Werte sind die aus dem Messwertblock, was wirklich am Poti anliegt, habe ich leider vergessen zu messen... heute Abend werde ich das Versäumnis nachholen ;)

@ FMode : Wenn du weitere Werte von mir brauchst, kann ich gerne weitere Dumps mit verschiedenen Einstellungen durchtesten ;)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »mr.b« (29. Januar 2010, 12:53)


FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

61

Freitag, 29. Januar 2010, 20:58

So anscheinend hatte ich die falsche Kennlinie in der Mache. Habe jetzt eine andere am Wickel, wo ich testweise alle Blöcke der Reihe auf einen Wert gestellt hatte. Dann tat sich beim Betätigen des Potis nichts an der Literangabe (immer bei 52l) und auch nicht an der Nadel, bis ich an einen bestimmten Ohm-Wert angelangt war, bis Nadel und Liter auf einmal auf Null fielen.
Darauf hin habe ich acht Test-Dumps fertig gemacht, wo ich je alle Blöcke auf einen Wert der Reihe gestellt hatte. Quasi Datei 1 alle auf Wert 1 aus der original Datei, in der 2. Datei alle Blöcke auf den Wert des 2. Blocks der originalen Datei. Ich hoffe ihr versteht was ich meine :wink
Die Schwelle wann die Nadel und die Literanzeige auf Null gefallen sind, haben sich von Datei zu Datei geändert. Habs mal in ein Diagramm zusammengestellt, und man kann daraus vielleicht was ableiten, ich jedenfalls noch nicht :D



So und hier mal eine 8 eingestellten Werte und die Schwelle, wann die Nadel abgefallen ist:

1. ... 267 ... 72 Ohm->52l ... 71 Ohm->0l
2. ... 302 ... 84 Ohm->52l ... 83 Ohm->0l
3. ... 322 ... 92 Ohm->52l ... 91 Ohm->0l
4. ... 336 ... 99 Ohm->52l ... 98 Ohm->0l
5. ... 385 ... 121 Ohm->25l ... 120 Ohm->0l ... ab 216 Ohm->26l (<-- das irritiert mich ein wenig!)
6. ... 471 ... 172 Ohm->52l ... 171 Ohm->0l
7. ... 537 ... 222 Ohm->52l ... 221 Ohm->0l
8. ... 589 ... 273 Ohm->52l ... 272 Ohm->0l

Die Nadel und Liter fallen im oberen Bereich wieder ab 347 Ohm auf 0.

EDIT: Die Ohm-Werte sind die aus dem Messwertblock, was wirklich am Poti anliegt, habe ich leider vergessen zu messen... heute Abend werde ich das Versäumnis nachholen ;)

@ FMode : Wenn du weitere Werte von mir brauchst, kann ich gerne weitere Dumps mit verschiedenen Einstellungen durchtesten ;)
das unterschiedliche Abfallen ist eben der 8. Wert der dort eine Grenze zu sein scheint.
Eventuell die flasche Kennlinie....
zuerst mal wollen wir doch aus sagen wir 200 Ohm nicht 30 sondern z.b. 20 Liter im Messblock angezeigt haben.
Also Widerstand fest einstellen und an den Kennlinien rumspielen - dabei immer Messwertblock Ohm kontrolliern!

(Grenzen kommen später)

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

62

Freitag, 29. Januar 2010, 21:06

Könnte sein, dass es doch auch die falsche Linie ist.

Werde morgen nach der Arbeit mal noch ein paar Tests machen, so wie du beschrieben hast ;)

Melde mich dann wieder!

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

63

Samstag, 30. Januar 2010, 19:27

So habe jetzt nochmal weiter mit den Kennlinien rumprobiert, und eigentlich kann es nur folgende Linie sein:

267 302 322 336 385 471 537 589 = 200 Ohm = 52 Liter

Dann habe ich mal folgende Werte durchgetestet:
50 100 150 200 300 400 500 600 = 200 Ohm = 38 Liter
75 150 225 300 375 450 525 600 = 200 Ohm = 35 Liter
150 225 300 375 450 525 600 675 = 200 Ohm = 22 Liter
225 300 375 450 525 600 675 750 = 200 Ohm = 22 Liter

Habe auch mal versucht die originalen Werte einfach umzudrehen, also was in 8 stand in 1, 7 in 2.. usw. Aber das funktioniert überhaupt nicht.

Bei der anderen Kennlinie habe ich ähnliches probiert, aber da hat sich Liter und Nadel nicht verändern. Die beiden übrigen Linie sind denke ich die Liter Linien mit Werten von 0 bis 52,5.

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

64

Donnerstag, 4. Februar 2010, 09:50

@ FMode : Hast du dir meine Werte mal angeschaut, kann man was draus ableiten? Komme momentan gar nicht weiter... ich seh da irgendwie noch keine Logik hinter :S

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

65

Freitag, 5. Februar 2010, 09:05


mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

66

Freitag, 5. Februar 2010, 09:41

Jup kenn ich schon, bezieht sich aber auf die 919er KIs, dort ist, wie ich irgendwo glaube ich schon geschrieben hatte, die Kennlinie anders abgelegt. Dort gibt es auch 8 Bytes in denen folgende Ohm-Werte abgelegt werden: leer, Reserve, 1/4, 1/2, 3/4, voll, voll, voll. Dies wäre einfach, aber bei den 920ier KIs nicht anwendbar :(

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mr.b« (5. Februar 2010, 10:23)


mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

67

Mittwoch, 10. Februar 2010, 12:08

Komm hier mit den Kennlinien nicht weiter, bin mir auch immer noch nicht sicher, ob ich die richtige Kennlinie in der Mache habe...

Jemand noch ein paar hilfreiche Informationen für mich?

FMode

Anfänger

  • »FMode« ist männlich

Beiträge: 28

Registrierungsdatum: 7. Januar 2008

Wohnort: Rhein-Main Gebiet

Autos: Passat W8

68

Dienstag, 23. Februar 2010, 18:08

so habe wieder ein Labor...

so jetzt habe ich die Tankgeberkennlinie auf Golf 3 angepasst (hoffe ich), 3764 als K-Zahl und die doofe Plateau-funktion vom Kühlmitteltempzeiger ist auch weg.
Ist ein 1J0 919 860D von VDO....

so dann lass mich mal in ein 920 reingucken... vielleicht sehe ich was.

Adressen:

Tank:
ca-d9 Ohm(?) (Einheit Umrechnung unbekannt)
da-e9 Liter c8 = 25 Liter, 190 = 50 Liter (8 pro Liter)
ea-f9 Zeiger

Zeiger temp:
106-101 tempkurve x
112-11d tempkurve y

K Zahl Codierung 1 : 92-95
»FMode« hat folgende Datei angehängt:
  • 1J0919860.zip (522 Byte - 11 mal heruntergeladen - zuletzt: 22. März 2016, 15:08)

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

69

Dienstag, 23. Februar 2010, 20:04

Ah, das hört sich doch schon gut an.
Die K-Kennzahl möchte ich auch noch anpassen, habe zwar das passende Getriebe zum Tacho, aber kleinere Reifen. Wie das funktioniert kannst mir ja bei Gelegenheit mal sagen ;)
Habe alle KIs diese Plateau-Funktion? Also hast du jetzt eine lineare Kurve drin?

Poste dir jetzt mal die passenden Abschnitte aus meinem Dump:

52-Liter Linien:

Quellcode

1
2
3
4
5
00000150	02D3	02B5	048E	0504	2040	0050	0008	0B01  # Linie A Offset 15E-16D ->Eingang?
00000160	2E01	4201	5001	8101	D701	1902	4D02	0000  # Linie B Offset 16E-17D -> Liter (0-52,5)
00000170	1A00	2A00	3600	6400	C800	2C01	A401	8008
00000180	0000	1A00	2A00	3600	6400	C800	2C01	A401  # Linie C Offset 180-18F -> Liter (0-52,5)
00000190	3000	8300	CE00	FD00	9501	ED02	4304	A805  # Linie D Offset 190-19F -> Stellmotor?


Und die 60-Liter Linien:

Quellcode

1
2
3
4
5
000002E0	0008	0B01	2E01	4201	5001	8101	D701	1902  # Linie E Offset 2E2-2F1 -> Eingang?
000002F0	4D02	0000	2000	3200	4000	7E00	FC00	7A01  # Linie F Offset 2F2-301 -> Liter (0-60)
00000300	E001	8008	0000	2000	3200	4000	7E00	FC00  # Linie G Offset 304-313 -> Liter (0-60)
00000310	7A01	E001	3000	8300	CE00	FD00	9501	ED02  # Linie H Offset 314-323 -> Stellmotor?
00000320	4304	A805	4050	FFFF	FFFF	0000	0000	0000

mr.b

Technik-Admin

  • »mr.b« ist männlich
  • »mr.b« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

70

Freitag, 2. Juli 2010, 11:57

So habe mich mit dem Thema aus Zeitmangel bis jetzt noch nicht wieder beschäftigt.
Hat jemand von euch weiter gemacht?
Kann es vielleicht auch sein, dass keine reinen Ohm-Werde sondern mVolt-Werte abgelegt sind in der von mir rausgesuchten Kurve?

Vielleicht ist ja noch jemand hier, der mit mir hier weiter experimentieren kann und will ;)

Markus (mr.b)

Technik-Admin

  • »Markus (mr.b)« ist männlich
  • »Markus (mr.b)« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

71

Dienstag, 11. Januar 2011, 15:48

Schon jemand weiter gedacht... oder weißt jemand, wie die Werte abgelegt sind... ?!

Copyright

Anfänger

  • »Copyright« ist männlich

Beiträge: 2

Registrierungsdatum: 15. November 2015

Wohnort: Hannover

Autos: VW Jetta MK2

72

Samstag, 21. November 2015, 08:46

Erster Post und dann gleich Leichenschänder *duckundweg*

Ich bin zur Zeit bei einer ähnliches Sache im Gange wie der Mr.B

deswegen die Frage, ob da damals was bei rum gekommen ist, wie die Werte zu ändern sind!?

LG

Max
Wer ander'n eine Bude baut, fährt selber kein'

Markus

Technik-Admin

  • »Markus« ist männlich
  • »Markus« ist der Autor dieses Themas

Beiträge: 3 371

Registrierungsdatum: 28. November 2002

Wohnort: Niedersachsen

Autos: VW Jetta II 1.8T, Seat Exeo ST Sport 2.0 TDI

73

Montag, 23. November 2015, 11:23

Hallo.

Leider ist das hier noch Stand der Dinge. mir ist es nicht gelungen den Datensatz anzupassen.

Copyright

Anfänger

  • »Copyright« ist männlich

Beiträge: 2

Registrierungsdatum: 15. November 2015

Wohnort: Hannover

Autos: VW Jetta MK2

74

Dienstag, 24. November 2015, 20:12

Ich werde mich der Thematik nun auch mal ein wenig annehmen und hoffe da etwas weiter zu kommen. Werde euch/dich hier auf dem laufenden halten. Habe mir auch ein Dongle bestellt mit dem ich vielleicht noch ein paar Sachen raus bekomme.

Wenn es was neues gibt, melde ich mich wieder.

Gesendet von meinem SM-G925F mit Tapatalk
Wer ander'n eine Bude baut, fährt selber kein'